Database integration health status
Each database integration has a health status that reflects whether recent connection tests, account discovery, and credential rotation are completing successfully.
Status values
The Status column is displayed on the Okta Privileged Access integrations list page. The status reflects the highest-severity issue that Okta Privileged Access currently detects for that integration.
- Healthy
- The integration has no known issues.
- Warning
- The integration has at least one warning-level issue and no error-level issues. Warning-level issues might be transient and might resolve on their own.
- Error
- The integration has at least one error-level issue. Error-level issues almost always require your intervention.
Select Warning or Error to see a list of all current issues for that integration. See Health issue codes.
Note:
Okta System Log records an event each time an integration's health status changes.
Health issue codes
| Error code | Severity | Description | How to fix |
|---|---|---|---|
| BAD_CREDENTIALS | Error | The integration user doesn't have all the required privileges. | Ensure that the integration user has all the privileges required for your database type. See Database integration user privileges. |
| EXTERNAL_ERROR | Warning | The database instance returned an error for the last attempt to discover accounts or rotate a database account password. | This issue originates on the database instance rather than in Okta Privileged Access. It might be transient and might resolve on the next attempt. To investigate, review your database logs and the Okta System Log. See Troubleshooting database integrations. |
| NETWORK_ERROR | Error | The gateway machine doesn't have network connectivity to the database instance. | Verify that the gateway machine has network access to the database instance on the correct port. See Network access by environment. |
| ORCHESTRATOR_TIMEOUT | Warning | The last attempt to discover accounts or rotate a database account password took too long and didn't complete. | This issue could be caused by momentary load on the database instance, unrelated to Okta Privileged Access, and might resolve on the next attempt. To investigate, review your database logs and the Okta System Log. See Troubleshooting database integrations. |
| READ_REPLICA | Error | The database instance that you're integrating with is read-only. | Integrate with the primary write instance. |