Troubleshooting: Microsoft SharePoint (On-Premises)

This topic provides solutions to common problems that may occur during the SharePoint (On-Premises) deployment.

The Trusted Identity Provider section is grayed out on the Edit Authentication page

Make sure Claims Based Authentication is selected as the preferred mode of authentication for this SharePoint application. From the Windows PowerShell command prompt, enter the following to set the specified user account as an administrator for the site:

$WebAppName = "http://" (http://)"

$wa = get­SPWebApplication $WebAppName

$wa.UseClaimsAuthentication = $true

$wa.Update()

Authentication fails and shows a web page with an error: "An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed"

Open the web.config file for this web application and make sure custom errors are turned off in the web.config file.

<system.web>

...

<customErrors mode="Off"/>

Authentication fails showing a web page with an error: "The Audience URI could not be validated"

Open the web.config file for this web application and add the following line:

(mode=Never)

<microsoft.identityModel>

....

<audienceUris mode="Never"/>

I see both Windows Authentication and Okta for SSO when I try to sign in

Both Windows Authentication and Okta are chosen as Identity Trust provider. Uncheck Windows Authentication if you want only Okta to act as a trust provider.

I changed authentication providers but there is no effect

Refer to http://technet.microsoft.com/en-us/library/cc288091(v=office.12).aspx. Resetting your IIS server (iisreset) should usually help.