État de santé de l'intégration de base de données
Chaque intégration de base de données présente un état de santé qui indique si les tests de connexion récents, la découverte des comptes et la rotation des identifiants sont exécutés correctement.
Valeurs de l'état
La colonne État s'affiche sur la page répertoriant les intégrations Okta Privileged Access. Ce statut correspond au problème présentant le niveau de gravité le plus élevé que Okta Privileged Access détecte actuellement pour cette intégration.
- Sain
- L'intégration ne présente aucun problème connu.
- Avertissement
- L'intégration présente au moins un problème de niveau « Avertissement » et aucun problème de niveau « Erreur ». Les problèmes de niveau « Avertissement » peuvent être passagers et se résoudre d'eux-mêmes.
- Erreur
- L'intégration comporte au moins un problème de niveau « Erreur ». Les problèmes de niveau « Erreur » nécessitent presque toujours votre intervention.
Sélectionnez Avertissement ou Erreur pour afficher la liste de tous les problèmes actuels liés à cette intégration. Voir Codes de problème de santé.
Remarque :
Le journal système Okta enregistre un événement chaque fois que l'état de santé d'une intégration change.
Codes de problème de santé
| Code d'erreur | Gravité | Description | Résolution des problèmes |
|---|---|---|---|
| BAD_CREDENTIALS | Erreur | L'utilisateur de l'intégration ne dispose pas de tous les privilèges requis. | Assurez-vous que l'utilisateur de l'intégration dispose de tous les privilèges requis pour votre type de base de données. Voir Privilèges de l'utilisateur pour l'intégration de base de données . |
| EXTERNAL_ERROR | Avertissement | L'instance de base de données a renvoyé une erreur lors de la dernière tentative de découverte de comptes ou de changement de mot de passe d'un compte de base de données. | Ce problème provient de l'instance de base de données plutôt que de Okta Privileged Access. Il peut être temporaire et se résoudre lors de la prochaine tentative. Pour enquêter, consultez les journaux de votre base de données et le journal système Okta. Voir Dépannage des intégrations de bases de données. |
| NETWORK_ERROR | Erreur | L'hôte de la passerelle n'a pas de connectivité réseau vers l'instance de base de données. | Vérifiez que l'hôte de la passerelle dispose d'un accès réseau à l'instance de base de données sur le port approprié. Voir Accès au réseau par environnement. |
| ORCHESTRATOR_TIMEOUT | Avertissement | La dernière tentative de découverte de comptes ou de changement de mot de passe d'un compte de base de données a pris trop de temps et n'a pas abouti. | Ce problème peut être causé par une charge momentanée sur l'instance de base de données, sans rapport avec Okta Privileged Access, et peut se résoudre lors de la prochaine tentative. Pour enquêter, consultez les journaux de votre base de données et le journal système Okta. Voir Dépannage des intégrations de bases de données. |
| READ_REPLICA | Erreur | L'instance de base de données que vous intégrez est en lecture seule. | Intégrer à l'instance d'écriture principale. |